Third party providers that support SMS text messageing services and support are operational, however may be slow.
Posted Oct 20, 2025 - 14:57 UTC
Investigating
The AWS Cloud outage on EST is not directly impacting AOK, however third party services providing text message delivery and support may be slow due to the outage.
Posted Oct 20, 2025 - 14:54 UTC
This incident affected: Mustr and SMS Text Notifications.